405错误是什么:
HTTP 405错误是HTTP协议状态码的一种,表示“对于请求所标识的资源,不允许使用请求行中所指定的方法。
405错误产生原因:
web服务器(容器)找不到service()方法处理请求。
如:
1)service方法名称写错
2)service方法参数类型与标准不一致
3)service方法异常、返回值类型与标准不一致
405常用解决办法:
文件目录权限不够:这多是NTFS文件格式造成的
(1)选择“工具”――“文件夹选项…”,在弹出窗口中点击“查看”,在查看窗口下取消“高级设置”窗口中“使用简单文件共享(推荐)”前面的复选框。然后点击“确定”。
(2)然后点击你要设置的文件夹的右键,在弹出窗口中选择“属性”――“安全”――“添加”一个“EVERYONE”用户名,并却赋予“完全控制”的权限。
IIS解析文件名有关:如果A页面通过表单(form)向B页面传递参数,而B页面是以“.htm or .html”为扩展名的话,通过IIS解析会出现“HTTP 错误 405 -禁止访问资源”错误的提示。原因是静态的文件无法通过IIS解析传递数据。
把接受参数的文件的扩展名修改为“.asp or .aspx"
deepin20桌面图标样式怎么修改? deepin更换图标主题的技巧
virtualbox打不开虚拟机怎么办? linux无法访问virtualbox的解决办法
deepin怎么注销系统? deepin系统注销与切换用户的方法
Manjaro linux怎么调鼠标速度? Manjaro鼠标设置光标速度的技巧
Kali Linux鼠标光主题怎么修改? 修改鼠标光标主题的技巧
deepin系统版本号怎么看? deepin系统查看系统版本信息的技巧