错误消息:超过了最大请求长度
错误原因:asp.net默认最大上传文件大小为4M,运行超时时间为90S。
解决方案
1. 修改web.config文件可以改变这个默认值
2.另一种方法是修改.NET FrameWork:
(1) 修改 C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/CONFIG 目录下的machine.config 文件。
(2) 查找 "
这样,你的任何一个 web 工程都可以上传最大8M的文件。
3.顺便说下IIS中限制上传文件大小的修改方法:
(1)首先要到进程中把IIS服务关了,即把inetinfo.exe进程关了。
(2)在系统目录中找到:windows/system32/inesrv/metabase.xml”文件,找个文本编辑器打开,查找AspMaxRequestEntityAllowed="204800"这一项,这就是iis上传文件的默认大小了,默认为204800Byte,也就是200KB,将它改为需要的大小就可以了。
Linux Lite 6.4今日发布基于 Ubuntu 22.04.2 LTS/原生应用支持 Zstd 压缩
0.1秒的价值!浅谈Web前端页面提速问题实用指南
Linux 6.3发布第4个候选版本 diffstat占比超过50%
linux无法识别ntfs格式U盘怎么办? 解决linux不识别nfst格式u盘问题技巧
Linux Mint 21.2 将于 6 月发布 主要改进了登录屏幕
请尽快升级 Ubuntu 18.04 LTS 和 Linux Mint 19.x 发行版将于 4 月停止支持