Linux网卡无法启动报错RTNETLINK answers File exists怎么办?

作者:袖梨 2026-09-27

在Linux主机上进行网卡参数配置修改后,经常会有重启网卡的情况,有时候网卡重启会出现报错RTNETLINK answers: File exists,这是什么原因造成的?详细请请看下文介绍。

img_64cb6fbe3814230.jpg

一、问题描述

Linux下通过service network restart命令重启网卡,出现如图重启失败报错。

img_64cb6fbe4762a31.jpg

二、查看问题详情

使用systemctl status network.service命令查看错误详情。

img_64cb6fbe5564432.jpg

三、原因分析与解决办法

出现这种报错一般是和 NetworkManager 服务冲突导致的,直接关闭 NetworkManger 服务就好了, service NetworkManager stop,并且禁止开机启动 systemctl disable NetworkManager

img_64cb6fbe6666433.jpg

重启网络服务

service network restart

img_64cb6fbe7624c34.jpg

检查网卡状态,显示active为正常

systemctl status network.service

img_64cb6fbe831ff35.jpg

注意事项:

Centos7之上使用命令systemctl disable NetworkManager 关闭自启动

相关文章

精彩推荐