在使用SQL2005(或2008)是可能会遇到错误提示:
“Windows 不能在 本地计算机 启动 SQL Server 。
有关更多信息,查阅系统事件日志。如果这是非 Microsoft 服务,请与服务厂商联系,并参考特定服务错误代码126 ”
解决方法:
在2005(2008)的“配置工具”中有个“SQL Server Configuration Manager”-->SQLserver 2005(2008) 的网络配置,
在MSSOLSERVER和SQLEXPRESS中都有个VIA的属性,你那个服务无法启动就把那个VIA设置禁用。
然后重启一下服务,就可以了。
我试过了是在2008中无法启动服务,
查看MSSOLSERVER和SQLEXPRESS中都有个VIA的属性,将VIA设置为禁用,然后重启服务,就可以了,服务能正常启动。
如果上面方法不行我们可尝试(不能在本地计算机启动SQL SERVER (MSSQLSERVER) 错误代码3417)
解决方案如下:
C:/Program Files/Microsoft SQL Server/MSSQL.1/MSSQL/Data下的所有mdf和ldf默认都是按照解压缩方式保存的,只需要右键每一个文件---属性---高级---压缩内容以便节省磁盘空间 的勾 去掉即可
deepin20怎么新增字体? deepin20安装字体的教程
Linux如何给文件权限? linux给文件添加可执行权限的技巧
deepin20桌面图标样式怎么修改? deepin更换图标主题的技巧
virtualbox打不开虚拟机怎么办? linux无法访问virtualbox的解决办法
deepin怎么注销系统? deepin系统注销与切换用户的方法
Manjaro linux怎么调鼠标速度? Manjaro鼠标设置光标速度的技巧