错误的原因
问题的原因是正常后台url地址应该是 /wp-admin/ 这种格式的,但是由于Nginx的原因是 /wp-admin 这种格式的
也就导致了错误。
Nginx认为只有后面有 / 的情况下才会认为是一个目录
解决办法
在 wp-admin/admin-header.php 中加入一段代码
加载到<?php 的上方就可以了
或者这样操作
1、登录shell,vim编辑Nginx配置目录(一般是在/usr/local/nginx/conf/)下的"wordpress.conf",当然如果你像我一样用的是自己写的conf文件,那就改对应的那个重定向配置文件就好。
vim /usr/local/nginx/conf/wordpress.conf2、把官方给的那一行加到文件最后面就行了
| 代码如下 | 复制代码 |
|
location /blog/ { |
|
deepin20怎么新增字体? deepin20安装字体的教程
Linux如何给文件权限? linux给文件添加可执行权限的技巧
deepin20桌面图标样式怎么修改? deepin更换图标主题的技巧
virtualbox打不开虚拟机怎么办? linux无法访问virtualbox的解决办法
deepin怎么注销系统? deepin系统注销与切换用户的方法
Manjaro linux怎么调鼠标速度? Manjaro鼠标设置光标速度的技巧