在做mysql5.5主从复制,当在从服务器上的执行CHANGE MASTER时,报下面这个错误:
ERROR 1201 (HY000): Could not initialize master info structure; more error messages can be found in the MySQL error log.
下面是解决方法:
1.先停止slave
stop slave;
2.进入数据库存储目录
我的mysql存储目录是/var/lib/mysql
cd /var/lib/mysql
删除以下两个文件:
rm -f master.info
rm -f relay-log.info
3.然后再启动slave
start slave;
再执行CHANGE MASTER就不会报错了.
如果你嫌删文件不好,那你也可以在停止slave后,执行下面的命令:
mysql> reset slave;
这样也是可以的 相关参考:http://www.*11*1c*om.net/database/mysql/52862.htm
Kali Linux怎么修改默认whisker菜单图标?
Kali Linux鼠标怎么设置左撇子模式? Linux鼠标左手操作的选择方法
deepin20怎么卸载软件程序? deepin卸载应用的两种方法
deepin20怎么使用画板打开图片? deepin画板打开图片的两种方法
deepin20默认浏览器怎么设置? deepin添加默认浏览器的技巧
deepin系统怎么设置屏幕分辨率? deepin分辨率的设置方法