我的PHP是IIS模式的,今天出现这种错误提示:FastCGI Error The FastCGI Handler was unable to process the request. //FastCGI无法处理请求,出现这种错误多见于在IIS中以FastCGI模式运行PHP的情况,原因是php.ini配置的问题,费话不多说,这里直接给出解决方法,不浪费时间。
1、打开php.ini找到register_globals = Off将其改为:
| 代码如下 | 复制代码 |
|
register_globals = On |
|
要注意此行前面的注释,也就是分号”;”是去掉的,本行是打开PHP的全局变量功能。
2、配置FastCGI文件:修改maxInstances值的大小:
| 代码如下 | 复制代码 |
|
[Types] |
|
如果按上面办法无法解决可
网上找一个msvcr71.dll 复制到你系统目录下
| 代码如下 | 复制代码 |
|
C:/Windows/System/System32 |
|
3、优化IIS应用程序池
设置最大使用的内存为2048M,也可以试其它值,可以亲自修改此值试一下,我改的值不一定就适合你,上述修改后要重启IIS
deepin20怎么新增字体? deepin20安装字体的教程
Linux如何给文件权限? linux给文件添加可执行权限的技巧
deepin20桌面图标样式怎么修改? deepin更换图标主题的技巧
virtualbox打不开虚拟机怎么办? linux无法访问virtualbox的解决办法
deepin怎么注销系统? deepin系统注销与切换用户的方法
Manjaro linux怎么调鼠标速度? Manjaro鼠标设置光标速度的技巧